Примеры функции СЧЁТЕСЛИ с несколькими условиями в Microsoft Excel

Содержание

  • Описание синтаксиса функции
  • Вариант 1: Счет текстовых условий
  • Вариант 2: Счет числовых условий
  • Вопросы и ответы

Функция «СЧЁТЕСЛИ», часто использующаяся в Excel, относится к критериям. Если у вас еще нет базовых понятий о функциях, относящихся к этой группе, ознакомьтесь с общим их описанием в инструкции по ссылке ниже.

Читайте также: Использование критериев в Microsoft Excel

Описание синтаксиса функции

Начать следует с описания синтаксиса самой функции «СЧЁТЕСЛИ», поскольку при работе с несколькими условиями понадобится создавать большую формулу, учитывая все особенности.

  • Для простоты понимания структуры предлагаем объявить в поле =СЧЁТЕСЛИ() и сразу перейти к меню «Аргументы функции».
  • Примеры функции СЧЁТЕСЛИ с несколькими условиями в Microsoft Excel

  • В нем вы увидите строки «Диапазон» и «Критерий». Нажмите по первой для ее активации.
  • Примеры функции СЧЁТЕСЛИ с несколькими условиями в Microsoft Excel

  • В качестве диапазона указывается выборка данных, которая и должна попадать в функцию. Проще всего ее указать путем выделения ячеек, не закрывая при этом текущее окно.
  • Примеры функции СЧЁТЕСЛИ с несколькими условиями в Microsoft Excel

  • Далее остается только добавить критерий во второе поле — то есть происходит указание самого условия. Не забывайте, что числа вписываются просто так, а текст берется в двойные кавычки.
  • Примеры функции СЧЁТЕСЛИ с несколькими условиями в Microsoft Excel

    Внизу под полями виден результат, что уже свидетельствует о правильном составлении функции. Сейчас добавить еще одно условие нельзя, поэтому формулу придется расширять, о чем и пойдет речь в следующих двух вариантах.

    Вариант 1: Счет текстовых условий

    Разберем ситуацию, когда есть два столбца с определенными значениями, которыми в нашем случае выступают месяцы. Нужно сделать выборку из них, чтобы в результате показывало значение того, сколько ячеек соответствуют заданному условию. Объединяются два условия при помощи одной простой формулы.

  • Создайте первую часть функции «СЧЁТЕСЛИ», указав в качестве диапазона первый столбец. Сама функция имеет стандартный вид: =СЧЁТЕСЛИ(A2:A25;»Критерий»).
  • Примеры функции СЧЁТЕСЛИ с несколькими условиями в Microsoft Excel

  • Добавьте знак сложения («+»), который и послужит соединительным для двух условий.
  • Примеры функции СЧЁТЕСЛИ с несколькими условиями в Microsoft Excel

  • Сразу же после него впишите вторую часть — =СЧЁТЕСЛИ(B2:B25;»Критерий») — и нажмите клавишу ввода.
  • Примеры функции СЧЁТЕСЛИ с несколькими условиями в Microsoft Excel

  • Если нужно, дописывайте любое количество плюсов, добавляя диапазоны и критерии точно в таком же ключе.
  • Примеры функции СЧЁТЕСЛИ с несколькими условиями в Microsoft Excel

    Проверьте результат, который отобразится в заданной клетке. Если вдруг возникла ошибка, удостоверьтесь в том, что вы правильно соблюли синтаксис функции, а ячейки в диапазоне имеют соответствующий формат.

    Вариант 2: Счет числовых условий

    С числовыми условиями дела обстоят точно так же, но на этот раз давайте рассмотрим более детальный пример ручного составления функции, учитывая каждую деталь.

  • После объявления «СЧЁТЕСЛИ» в круглых скобках задайте диапазон чисел «A1:A25», где вместо указанных ячеек подставьте необходимые.
  • Примеры функции СЧЁТЕСЛИ с несколькими условиями в Microsoft Excel

  • Сразу за диапазоном без пробела добавьте знак «;», который объявляет его закрытие.
  • Примеры функции СЧЁТЕСЛИ с несколькими условиями в Microsoft Excel

  • После него просто напишите число, которое хотите посчитать.
  • Примеры функции СЧЁТЕСЛИ с несколькими условиями в Microsoft Excel

  • Поставьте знак «+» и допишите вторую часть формулы точно так же.
  • Примеры функции СЧЁТЕСЛИ с несколькими условиями в Microsoft Excel

  • Как только вы нажмете клавишу Enter, в ячейке отобразится число, которое и будет результатом математического действия с двумя указанными критериями.
  • Примеры функции СЧЁТЕСЛИ с несколькими условиями в Microsoft Excel

    Добавить комментарий

    Ваш e-mail не будет опубликован. Обязательные поля помечены *